Search this Blog

Sunday, April 13, 2014

How to extract this specific data and use it for WLC SNMP historical purposes?


 Our organization has a business requirement to track all wireless users.  We use the techniques outlined in this document to take a "snap-shot" of our wireless clients associated with a Cisco WLC every 5 minutes and import that data into Splunk, where we can index and search through it any time we want.
This document will cover some basics needed to successfully extract connected client data from a Cisco WLC via SNMP. How to extract this specific data and use it for historical purposes.  This document will provide MIB information to key OIDs of value, a bash scripting example, and lessons learned.

SNMP MIBs:
Cisco provides excellent SNMP MIB documentation.  For those who don't know what a MIB is, it stands for Management Information Base.  A MIB is like a road map for SNMP enabled systems.  The MIB allows you to identify and navigate to key data points that you wish to query.  Without a MIB for a corresponding piece of equipment, you will be making arbitrary requests for seemingly random data-points.
Please click here to find what you are looking for is to use Cisco's SNMP Object.
This tool allows you to step through an SNMP tree and locate the OID you are looking for, so you can query the data you want.  In this tutorial we will be using the SNMP tool suite for Linux and the snmpget and snmpwalk commands specifically.
The OIDS below will be what we focus on.
AP Names:
1.3.6.1.4.1.14179.2.2.1.1.3
Client MAC Address List:
1.3.6.1.4.1.14179.2.1.4.1.1
snmpwalk -v 2c -O x -c public 10.1.1.252 1.3.6.1.4.1.14179.2.1.4.1.1
Client IP Address List:
1.3.6.1.4.1.14179.2.1.4.1.2
snmpwalk -v 2c -c public 10.1.1.252 1.3.6.1.4.1.14179.2.1.4.1.2
Client Username List:
1.3.6.1.4.1.14179.2.1.4.1.3
snmpwalk -v 2c -c public 10.1.1.252 1.3.6.1.4.1.14179.2.1.4.1.3
AP MAC Address List:
1.3.6.1.4.1.14179.2.1.4.1.3
snmpwalk -v 2c -O x -c public 10.1.1.1.252 1.3.6.1.4.1.14179.2.1.4.1.4
Client SSID List:
1.3.6.1.4.1.14179.2.1.4.1.7
snmpwalk -v 2c -c public 10.1.1.252 1.3.6.1.4.1.14179.2.1.4.1.7
-=EXAMPLE OUTPUT=-
SNMPv2-SMI::enterprises.14179.2.1.4.1.1.252.199.52.222.11.140 = Hex-STRING: FC C7 34 DE 0B 8C
SNMPv2-SMI::enterprises.14179.2.1.4.1.2.252.199.52.222.11.140 = IpAddress: 10.1.11.21
SNMPv2-SMI::enterprises.14179.2.1.4.1.3.252.199.52.222.11.140 = STRING: "jdoe"
SNMPv2-SMI::enterprises.14179.2.1.4.1.4.252.199.52.222.11.140 = Hex-STRING: 84 78 AC B8 2F 90
Using the above OIDs and command examples we can collect the data we want.
By querying 1.3.6.1.4.1.14179.2.1.4.1.1 we get a complete list of client MAC addresses currently associated with the WLC.  You may have noticed in the example output, that the different pieces of information all contain the same unique sequence on the end of the query.  (Ex.
252.199.52.222.11.140)  This will allow us to query a specific user's attributes.  Now that we know the basics of SNMP and know where the data is, we can start scripting to put everything into a more readable format.
Script Example:
(Please excuse my scripting.  I'm no coder.  This is for practical application and demonstration purposes only.)
The script example below is a bash script that was designed to be cron'd on a Linux host.  The output of the script looks like this:
SYSTEM=CISCO MAC=E4:D5:3D:3B:81:4D IP=10.1.0.233 USER=DOMAIN\\jdoe17 AP=84:78:AC:B8:33:F0 SSID=Marketing
SYSTEM=CISCO MAC=E8:3E:B6:3B:CA:8D IP=10.1.240.243 USER=Unknown AP=84:78:AC:B8:8A:E0 SSID=Guest
SYSTEM=CISCO MAC=EC:85:2F:14:A9:BA IP=10.1.248.197 USER=Unknown AP=1C:E6:C7:1C:D8:90 SSID=Guest
SYSTEM=CISCO MAC=F0:1C:13:09:0E:B2 IP=10.1.252.151 USER=Unknown AP=54:78:1A:71:81:B0 SSID=Guest
SYSTEM=CISCO MAC=F0:4F:7C:B9:5F:B3 IP=10.1.0.221 USER=jdoe12 AP=54:78:1A:71:81:B0 SSID=Marketing
SYSTEM=CISCO MAC=F0:4F:7C:D6:0A:D9 IP=10.1.251.29 USER=Unknown AP=54:78:1A:70:EE:10 SSID=Guest
SYSTEM=CISCO MAC=F0:A2:25:A7:BD:F5 IP=10.1.251.85 USER=Unknown AP=84:78:AC:B8:8C:60 SSID=Guest
SYSTEM=CISCO MAC=F0:CB:A1:32:B3:D0 IP=10.1.136.163 USER=jdoe76 AP=84:78:AC:B8:8C:60 SSID=Admin-Wifi
SYSTEM=CISCO MAC=F0:CB:A1:C7:2E:6F IP=10.1.0.179 USER=jdoe1 AP=84:78:AC:B8:33:F0 SSID=Marketing
SYSTEM=CISCO MAC=F0:D1:A9:6E:05:2A IP=10.1.248.141 USER=Unknown AP=54:78:1A:71:D7:00 SSID=Guest
SYSTEM=CISCO MAC=F0:D1:A9:92:5C:7F IP=10.1.0.164 USER=jdoe23 AP=1C:E6:C7:1C:D3:E0 SSID=Marketing
SYSTEM=CISCO MAC=F0:DC:E2:02:4F:35 IP=10.1.248.104 USER=Unknown AP=54:78:1A:71:D7:00 SSID=Guest
SYSTEM=CISCO MAC=F0:DC:E2:BF:E1:A1 IP=10.1.0.240 USER=jadoe4 AP=84:78:AC:B8:33:F0 SSID=Marketing
SYSTEM=CISCO MAC=F4:6D:E2:E9:69:58 IP=10.1.252.180 USER=Unknown AP=54:78:1A:71:BF:B0 SSID=Guest
SYSTEM=CISCO MAC=F8:D0:BD:2F:BF:21 IP=10.1.0.128 USER=jdoe48 AP=1C:E6:C7:1C:D8:90 SSID=Marketing
SYSTEM=CISCO MAC=F8:DB:7F:9F:5A:22 IP=10.1.252.182 USER=Unknown AP=1C:E6:C7:1D:2F:60 SSID=Guest
SYSTEM=CISCO MAC=FC:C7:34:DE:0B:8C IP=10.1.0.44 USER=jdoe1 AP=84:78:AC:B8:2F:90 SSID=Marketing
(*NOTE:  This format is easily digested by Splunk or syslog)
Example Script:
#!/bin/bash
##########################
snmp_community="public"   
snmp_host="10.1.1.252"   
###########################
rm -f /tmp/cn-wlc.txt
####################################################################
#Set input system to break on new-line when adding data to an array#
####################################################################
IFS=$'\n'
############################################################################################
#Perform SNMP walks to get data of interest and load them into array variables to use later#
############################################################################################
while [ "1" -ne "2" ]
do
Unique_OID=($(snmpwalk -v 2c -O x -c $snmp_community $snmp_host 1.3.6.1.4.1.14179.2.1.4.1.1))
Client_IP=($(snmpwalk -v 2c -c $snmp_community $snmp_host 1.3.6.1.4.1.14179.2.1.4.1.2))
Client_Username=($(snmpwalk -v 2c -c $snmp_community $snmp_host 1.3.6.1.4.1.14179.2.1.4.1.3))
Client_AP=($(snmpwalk -v 2c -O x -c $snmp_community $snmp_host 1.3.6.1.4.1.14179.2.1.4.1.4))
Client_SSID=($(snmpwalk -v 2c -c $snmp_community $snmp_host 1.3.6.1.4.1.14179.2.1.4.1.7))
############################################################################################
#Ensure all SNMP walk requests contain the same amount of data and break loop when they do #
############################################################################################
 
count1=${#Unique_OID[@]}
count2=${#Client_IP[@]}
count3=${#Client_Username[@]}
count4=${#Client_AP[@]}
count5=${#Client_SSID[@]}
if [ "$count1" -eq "$count2" ]; then
                  if [ "$count2" -eq "$count3" ]; then
                        if [ "$count3" -eq "$count4" ]; then
                                       if [ "$count4" -eq "$count5" ]; then
                                                                  break
                                                          fi
                        fi
         fi
fi
done
####################################################################
#Create a loop to match and extract data between the various arrays#
####################################################################
wait
index=0
while [ "$index" -lt "$count1" ]
      do    
           id=$(echo ${Unique_OID[$index]} | cut -d "=" -f1 | awk -F "." '{print $8 "."$9 "." $10 "." $11 "." $12 "." $13 }')
           cMAC=$(echo ${Unique_OID[$index]} | grep $id | awk -F " " '{print $4 ":" $5 ":" $6 ":" $7 ":" $8 ":" $9 }')
           cIP=$(echo ${Client_IP[$index]} | grep $id | awk -F " " '{print $4}')
           cUser=$(echo ${Client_Username[$index]} | grep $id | awk -F " " '{print $4}' | sed s/\"//g)
           cAP=$(echo ${Client_AP[$index]} | grep $id | awk -F " " '{print $4 ":" $5 ":" $6 ":" $7 ":" $8 ":" $9 }')
           cSSID=$(echo ${Client_SSID[$index]} | grep $id | awk -F " " '{print $4}' | sed s/\"//g)
                  if [ "$cUser" = "\"\"" ]; then
                          cUser="Unknown"
                  fi
                  if [ "$cUser" = "" ]; then
                        cUser="Unknown"
                  fi
                  if [ "$cIP" = "0.0.0.0" ]; then
                        donothing="True"
                  else
                          # write our data out to a file so we can do something with it later
                          echo "SYSTEM=CISCO MAC="$cMAC "IP="$cIP "USER="$cUser "AP="$cAP "SSID="$cSSID >> /tmp/cn-wlc.txt
                          #echo "SYSTEM=CISCO MAC="$cMAC "IP="$cIP "User="$cUser "AP="$cAP "SSID="$cSSID
                  fi
           ((index++))
     done
Lessons Learned:
  1. MAC address entries need to be queried with the SNMP option -O x so that they only return results in HEX.  I had several cases where a client was improperly displaying it's MAC address in ASCII and it contained line breaks that was messing everything up.  I don't know why or how the controller let that happen, but it was the controller that saved the data into that SNMP value.  The solution was to ensure that SNMP get and walks only returned HEX values for those querys.
  2. By default SNMP query results have spaces and by default bash arrays interpret spaces on array input as field separators.  Modifying IFS will fix this for you, as noted in the script above.
  3. In order to have a working set of data, you need to ensure all SNMP queries contain the same number of results.  If they do not match, you are querying user data for users who may no-longer be associated.  To combat this, I threw the whole get sequence into a loop.  It runs fast enough to eventually get the data I need.  I am sure there are better ways, but this works fine for now.
  4. Sometimes users show up with a 0.0.0.0 IP.  I assumed these users are in a limbo state waiting to be fully associated or until their PEAP authentication passed.  In any case, they aren't realistically on my network so I didn't care and discarded the results for their connections.  I interpreted this data as the controller creating a placeholder for them until they are associated.
Summary:
With the data you can collect using Cisco's MIBs and SNMP there is no limit to what information your gear can show you.  My organization has used it with great success to meet business requirements.  Being able to historically see who was on your wireless network at any time will give you a huge advantage.  We can turn around DMCA notices, track users, identify usage peaks and wireless trends at various facilities, and to a certain degree, identify coverage issues.  We also have a similar script to collect this same data from Meru systems as well.  Although this guide may not be perfect and the scripting could be improved, I felt it necessary to share. 

Citation - This blog post does not reflect original content from the author. Rather it summarizes content that are relevant to the topic from different sources in the web. The sources might include any online discussion boards, forums, websites and others.

Why is Cisco 8941/8945 IP Phone Stuck or Frozen with "Upgrade in progress"?

The Cisco Unified IP Phone 8941 and 8945 may become stuck, hung, or frozen with "Upgrade in progress" on the display.  When this happens the spinning progress icon will stop spinning and the phone will not respond to button presses.How do we solve this?

This occurs when an 8941 or 8945 phone is running firmware version 9.3(2)SR1 or earlier and a firmware upgrade is attempted to version 9.4(1).  In order to upgrade the phone to firmware version 9.4(1) from 9.3(2)SR1 or earlier a stepped upgrade is required.  Firmware Release 9.4(1) can be upgraded only from Release 9.3(4).  
To recover a phone that is stuck at the "Upgrade in progress" screen due to trying to upgrade to firmware version 9.4(1) from a source firmware version other than 9.3(4) the phone will need to be powered cycled.  Power cycle the phone only after changing the phone load in Cisco Unified Communications Manager (CUCM) to 9.3(4) instead of 9.4(1) to fulfil the stepped upgrade requirement.  After the phone has successfully upgraded to firmware version 9.3(4) the phone can be upgraded to 9.4(1).

Citation - This blog post does not reflect original content from the author. Rather it summarizes content that are relevant to the topic from different sources in the web. The sources might include any online discussion boards, forums, websites and others.

Saturday, April 12, 2014

How are the X25 confguration done ?


What are the steps to follow in configuring , veryfing and debugging the X25?

TOPOLOGY
router-2800-2 --Serial1/0----------------------------------Serial2/0--X25-switch-2900-4--s0/1/0:1-----------------------------------------s0/3/0:1---router-2800-3
CONFIGURATION
2800-2#sh run int s1/0
interface Serial1/0
ip address 10.1.1.1 255.255.255.0
encapsulation x25
x25 address 1234
x25 map ip 10.1.1.2 5678 broadcast
dsu bandwidth 44210
end
2800-3#sh run int s0/3/0:1
interface Serial0/3/0:1
ip address 10.1.1.2 255.255.255.0
encapsulation x25
x25 address 5678
x25 map ip 10.1.1.1 1234 broadcast
end
2900-4#conf t
2900-4#x25 routing
2900-4#x25 route 1234 interface Serial2/0
2900-4#x25 route 5678 interface Serial0/1/0:1
2900-4#sh run int s2/0
interface Serial2/0
no ip address
encapsulation x25 dce
dsu bandwidth 44210
end
2900-4#sh run int s0/1/0:1
interface Serial0/1/0:1
no ip address
encapsulation x25 dce
VERIFICATION
2900-4#sh x25 route
# Match                         Substitute         Route to     match/use
1 dest 1234                                         Serial2/0               0/0
2 dest 5678                                         Serial01/0:1         1/1
2800-2#sh x25 vc
SVC 1024, State: D1, Interface: Serial1/0
Started 00:10:07, last input 00:10:02, output 00:10:02
Connects 5678 <-> ip 10.1.1.2
Call PID cisco, Data PID none
Window size input: 2, output: 2
Packet size input: 128, output: 128
PS: 6 PR: 6 ACK: 5 Remote PR: 6 RCNT: 1 RNR: no
P/D state timeouts: 0 timer (secs): 0
data bytes 3000/3000 packets 30/30 Resets 0/0 RNRs 0/0 REJs 0/0 INTs 0/0
2800-2#ping 10.1.1.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.1.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/4/8 ms
2800-2#sh int s1/0
Serial1/0 is up, line protocol is up
Hardware is DSXPNM Serial
Internet address is 10.1.1.1/24
MTU 4470 bytes, BW 44210 Kbit/sec, DLY 200 usec,
     reliability 255/255, txload 1/255, rxload 1/255
Encapsulation X25, crc 16, loopback not set
Keepalive set (10 sec)
X.25 DTE, version 1984, address 1234, state R1, modulo 8, timer 0
     Defaults: idle VC timeout 0
       cisco encapsulation
     RESTARTs 0/0 CALLs 1+3/0+0/0+0 DIAGs 0/0
LAPB DTE, state CONNECT, modulo 8, k 7, N1 35816, N2 20
2800-2#sh x25 map
Serial1/0: X.121 5678 <-> ip 10.1.1.2
permanent, broadcast, 1 VC: 1024
“debug x25 packet” on 2900-2 while ping 10.1.1.2 from 2800-2 , packets being sent out (O) and received in (I)
2900-4#debug x25I
X.25 packet debugging is on
2900-4#
*May 27 02:17:02.946: Serial2/0: X.25 I D1 Data (103) 8 lci 1024 PS 3 PR 3
*May 27 02:17:02.946: Serial0/1/0:1: X.25 O D1 Data (103) 8 lci 1 PS 3 PR 3
*May 27 02:17:02.950: Serial0/1/0:1: X.25 I D1 Data (103) 8 lci 1 PS 3 PR 4
*May 27 02:17:02.950: Serial2/0: X.25 O D1 Data (103) 8 lci 1024 PS 3 PR 4
*May 27 02:17:02.950: Serial2/0: X.25 I D1 Data (103) 8 lci 1024 PS 4 PR 4
*May 27 02:17:02.950: Serial0/1/0:1: X.25 O D1 Data (103) 8 lci 1 PS 4 PR 4
*May 27 02:17:02.954: Serial0/1/0:1: X.25 I D1 Data (103) 8 lci 1 PS 4 PR 5
*May 27 02:17:02.954: Serial2/0: X.25 O D1 Data (103) 8 lci 1024 PS 4 PR 5
*May 27 02:17:02.954: Serial2/0: X.25 I D1 Data (103) 8 lci 1024 PS 5 PR 5
*May 27 02:17:02.954: Serial0/1/0:1: X.25 O D1 Data (103) 8 lci 1 PS 5 PR 5
*May 27 02:17:02.958: Serial0/1/0:1: X.25 I D1 Data (103) 8 lci 1 PS 5 PR 6
*May 27 02:17:02.958: Serial2/0: X.25 O D1 Data (103) 8 lci 1024 PS 5 PR 6
*May 27 02:17:02.958: Serial2/0: X.25 I D1 Data (103) 8 lci 1024 PS 6 PR 6
*May 27 02:17:02.958: Serial0/1/0:1: X.25 O D1 Data (103) 8 lci 1 PS 6 PR 6
*May 27 02:17:02.962: Serial0/1/0:1: X.25 I D1 Data (103) 8 lci 1 PS 6 PR 7
*May 27 02:17:02.962: Serial2/0: X.25 O D1 Data (103) 8 lci 1024 PS 6 PR 7
*May 27 02:17:02.962: Serial2/0: X.25 I D1 Data (103) 8 lci 1024 PS 7 PR 7
*May 27 02:17:02.962: Serial0/1/0:1: X.25 O D1 Data (103) 8 lci 1 PS 7 PR 7
*May 27 02:17:02.966: Serial0/1/0:1: X.25 I D1 Data (103) 8 lci 1 PS 7 PR 0
*May 27 02:17:02.966: Serial2/0: X.25 O D1 Data (103) 8 lci 1024 PS 7 PR 0
“debug x25 events” on 2900-2 while shut and no shut on int s1/0 on 2800-2 , look for cause code.
2900-4#
*May 27 02:19:42.314: Serial2/0: X.25 O R/Inactive Restart (5) 8 lci 0
*May 27 02:19:42.314:  Cause 7, Diag 0 (Network operational/No additional information)
*May 27 02:19:42.314: Serial2/0: X.25 I R3 Restart (5) 8 lci 0
*May 27 02:19:42.314:   Cause 0, Diag 0 (DTE originated/No additional information)


X25 over tcp coming soon ....... keep checking.....

Citation - This blog post does not reflect original content from the author. Rather it summarizes content that are relevant to the topic from different sources in the web. The sources might include any online discussion boards, forums, websites and others.

What are the configuration steps for VWIC-MFT?


What are the steps involoved in configuring VWIC-MFT and MultiLink PPP for data?

In this example we just installed 2 2-port VWIC-MFT cards, one is slot and  one is slot 3. Once installed you'll notice no additional serial interfaces nor  controller cards. However a show inventory shows the cards are installed.
NAME: "VWIC2-2MFT-T1/E1 - 2-Port RJ-48 Multiflex Trunk -  T1/E1 on Slot 0 SubSlot 2", DESCR: "VWIC2-2MFT-T1/E1 - 2-Port RJ-48 Multiflex  Trunk - T1/E1"
PID: VWIC2-2MFT-T1/E1  , VID: V01 , SN: FOC1228####
NAME: "VWIC2-2MFT-T1/E1 - 2-Port RJ-48 Multiflex Trunk - T1/E1 on Slot 0 SubSlot  3", DESCR: "VWIC2-2MFT-T1/E1 - 2-Port RJ-48 Multiflex Trunk - T1/E1"
PID: VWIC2-2MFT-T1/E1  , VID: V01 , SN: FOC1228####
Our first task is to configure the card type. These are T1's so let's  configure that.
card type t1 0 2
card type t1 0 3
Note that the 0 is from the Slot number (see show inventory) and the 2 is the  SubSlot number.

You should now see 4 new controllers. Let's configure them next.
controller T1 0/2/0
framing esf
linecode b8zs
clock source line independent <--- br="" case="" in="" internal="" is="" it="" not="" style="outline: none;" the="">channel-group 0 timeslots 1-24
!
controller T1 0/2/1
framing esf
linecode b8zs
clock source line independent <--- case="" font="" in="" internal="" is="" it="" not="" the="">
channel-group 0 timeslots 1-24
!
controller T1 0/3/0
framing esf
linecode b8zs
clock source line independent <--- case="" in="" internal="" is="" it="" not="" span="" the="">
channel-group 0 timeslots 1-24
!
controller T1 0/3/1
framing esf
linecode b8zs
clock source line independent <--- case="" in="" internal="" is="" it="" not="" span="" the="">
channel-group 0 timeslots 1-24
The reason for the "independent" keyword is to have the interfaces in the VWIC card to work with separate "clocking domain" one from the other.
Now that we have the controllers configured you should see 4 new serial  interfaces.
Serial0/2/0:0 unassigned YES manual down down
Serial0/2/1:0 unassigned YES manual down down
Serial0/3/0:0 unassigned YES manual down down
Serial0/3/1:0 unassigned YES manual down down
Now we can configure the serial interfaces.
interface Serial0/2/0:0
no ip address
encapsulation ppp
multilink
ppp multilink group 2

interface Serial0/2/1:0
no ip address
encapsulation ppp
ppp multilink
ppp multilink group 2

interface Serial0/3/0:0
no ip address
encapsulation ppp
ppp multilink
ppp multilink group 2

interface Serial0/3/1:0
no ip address
encapsulation ppp
ppp multilink
ppp multilink group 2
Finally let's configure the virtual MultiLink2 interface.
interface Multilink2
  description MLPPP Link for Point-To-Point
  ip unnumbered FastEthernet0/0
  ip route-cache flow
  no ip mroute-cache
  ppp multilink
  ppp multilink links maximum 4
  ppp multilink group 2
  ppp multilink fragment disable
Don't forget your routing (if needed)!

Citation - This blog post does not reflect original content from the author. Rather it summarizes content that are relevant to the topic from different sources in the web. The sources might include any online discussion boards, forums, websites and others.

How do we load an IOS on a switch via Xmodem?

There are times when the IOS on a switch may crash and (as a last resort) you need to use the painfully slow Xmodem transfer to save your life. What are the steps to load an IOS on a switch via Xmodem?

You can set the baud  rate in ROMMON using the set BAUD command. See below:
switch: set BAUD 57600
This MUST also match on the terminal program setting as well. So (I’m  using TeraTerm) under Setup -> Serial Port, set the baud rate to  match whatever you set it as in ROMMON. Now we’re ready to transfer the  file. The command is very straight forward:
switch: copy xmodem: flash:c3550-ipservicesk9-mz.122-44.SE6.bin
Once you press enter, you see the following:
Begin the Xmodem or Xmodem-1K transfer now…
C
At this point, you need to choose the file location from the terminal  program. Go under File -> Transfer -> Xmodem -> Send and  choose the file that you wish the transfer. The transfer will start and  you will see a transfer window pop up like this:
untitled.png
Once completed, you should get a prompt back to your ROMMON:
Begin the Xmodem or Xmodem-1K transfer now…
C…………………………………………………………………….                                                                                                 ……………………………………………………………………..                                                                                                 ……………………………………………………………………..                                                                                                 ……………………………………………………………………..                                                                                                 ……………………………………………………………………..                                                                                                 ……………………………………………………………………..                                                                                                 ……………………………………………………………………..                                                                                                 ……………………………………………………………………..                                                                                                 ……………………………………………………………………..                                                                                                 ……………………………………………………………………..                                                                                                 ……………………………………………………………………..                                                                                                 ……………………………………………………………………..                                                                                                 ……………………………………………………………………..                                                                                                 ……………………………………………………………………..                                                                                                 ……………………………………………………………………..                                                                                                 ……………………………………………………………………..                                                                                                 ……………………………………………………………………..                                                                                                 ……………………………………………………………………..                                                                                                 ……………………………………………………………………..                                                                                                 ……………………………………………………………………..                                                                                                 ……………………………………………………………………..                                                                                                 ……………………………………………………………………..                                                                                                 ……………………………………………………………………..                                                                                                 ……………………………………………………………………..                                                                                                 ……………………………………………………………………..                                                                                                 ……………………………………………………………………..                                                                                                 ……………………………………………………………………..                                                                                                 ……………………………………………………………………..                                                                                                 ……………………………………………………………………..                                                                                                ……………………………………………
File “xmodem:” successfully copied to “flash:c3550-ipservicesk9-mz.122-44.SE6.bin”
Now from ROMMON, boot from flash using the following command:
switch: boot flash:c3550-ipservicesk9-mz.122-44.SE6.bin
This will try to boot the IOS specified and if the transfer was good, then this should go smoothly.
Loading  “flash:c3550-ipservicesk9-mz.122-44.SE6.bin”…#########################                                                                                                 ################################################################################                                                                                                 ################################################################################                                                                                                 ################################################################################                                                                                                 ################################################################################                                                                                                 ################################################################################                                                                                                 ################################################################################                                                                                                 ################################################################################                                                                                                 ################################################################################                                                                                                 ################################################################################                                                                                                 ################################################################################                                                                                                 ################################################################################                                                                                                 ################################################################################                                                                                                 ################################################################################                                                                                                 ################################################################################                                                                                                ########
File “flash:c3550-ipservicesk9-mz.122-44.SE6.bin” uncompressed and installed, entry point: 0×3000
executing…
All’s good again!! The switch runs a POST, once everything checks out, you’re back into the familiar territory! :)
        — System Configuration Dialog —
Would you like to enter the initial configuration dialog? [yes/no]: no


Citation - This blog post does not reflect original content from the author. Rather it summarizes content that are relevant to the topic from different sources in the web. The sources might include any online discussion boards, forums, websites and others.
 
/* Google Analytics begin ----------------------------------------------- */ /* Google Analytics end ----------------------------------------------- */