Search this Blog

Thursday, December 16, 2010

Phone Time or timezone problem

We have two customers right now with problems with the time zone on their phones.

Customer 1:

  • 7921 CP7921G-1.3.3
  • 7940 P00308010100

Both this models display a wrong time (-1 of current time)

  • 7906 SCCP11.8-5-2SR1S

This model displays a correct time.

Customer's running CUCM 7.1.3.20000-2

NTP seems correct:

admin:utils ntp status
ntpd (pid 24900) is running...

remote refid st t when poll reach delay offset jitter
==============================================================================
127.127.1.0 LOCAL(0) 10 l 28 64 377 0.000 0.000 0.004
*X.XXX.X.XX XXX.XXX.X.XXX 3 u 642 1024 377 6.884 -9.076 3.476


synchronised to NTP server (X.XXX.X.XX) at stratum 4
time correct to within 115 ms
polling server every 1024 s

Current time in UTC is : Wed Oct 27 14:14:38 UTC 2010
Current time in Europe/Lisbon is : Wed Oct 27 15:14:38 WEST 2010
admin:

Date/Time Group is configured to (GMT) Europe/London * (Compatible with legacy phones)

Customer 2:

  • 6941 SCCP69xx.9-0-3-a

This models display a wrong time (-1 of current time)

  • 7962 SCCP42.9-0-2SR1S

This model displays a correct time.

Customer's running CUCM 7.1.5.30000-1

NTP also seems correct:

admin:utils ntp status
ntpd (pid 31403) is running...

remote refid st t when poll reach delay offset jitter
==============================================================================
127.127.1.0 LOCAL(0) 10 l 39 64 377 0.000 0.000 0.004
*XXX.XXX.XX.XX XXX.XXX.XX.XX 4 u 438 1024 377 0.526 0.797 23.508
synchronised to NTP server (XXX.XXX.XX.XX) at stratum 5
time correct to within 304 ms
polling server every 1024 s

Current time in UTC is : Wed Oct 27 14:13:56 UTC 2010
Current time in Europe/Lisbon is : Wed Oct 27 15:13:56 WEST 2010
admin:

Date/Time Group is configured to (GMT) Europe/London * (Compatible with legacy phones)

It seems to me that old legacy phones (7921, 7940) and new budget phones (69XX) seem to be affected with this problem.

We've searched online and found nothing. Did any of you had this problems?

Tips:

This is a known defect : Click here for bug details .

7940/7960/69XX phones are showing 1 hour before the real time.

The following versions are affected:
* 7.1.3: all CM versions below 007.001(003.33031.001)
* 7.1.5: all CM versions below 007.001(005.12008.001)
* 8.0.2: all CM versions below 008.000(002.41007.001), 8.0.3 shouldn't be affected.

We already have COP files for the 3 branches mentioned above:
Click here for 7.1.3
ciscocm.dst-updater.2010i-1.el4.7.1.3.cop.sgn
Click here for 7.1.5
ciscocm.dst-updater.2010i-1.el4.7.1.5.cop.sgn
Click here for 8.0
ciscocm.dst-updater.2010i-1.el4.8.0.2.cop.sgn

Please bear in mind the following suggestions when installing the COP
files:
- Installation to all machines in the cluster is required
- As with any installation or upgrade, it is recommended that you apply this Update during off peak hours.
- When applying this Package be advised that a cluster wide reboot is required.
- It is also recommended that this update be installed on all machines in the cluster before the cluster is rebooted.

Citation - This blog post does not reflect original content from the author. Rather it summarizes content that are relevant to the topic from different sources in the web. The sources might include any online discussion boards, forums, websites and others.

1 comment :

  1. Great post thanks for sharing a informative article keep it up
    Telephone Solution

    ReplyDelete

 
/* Google Analytics begin ----------------------------------------------- */ /* Google Analytics end ----------------------------------------------- */