Search this Blog

Sunday, February 27, 2011

Future IPV6-what is going on in the IPV4 to IPV6 migration?

We are trainers in AUDIO / VIDEO products , more and more we are in contact with switches an routers to build up some systems.More and more our dealers are confused with what is going on in the IPV4 to IPV6 migration , they are afraid that the LAN they build today will be useless after the 8 of June 2011 or later. So far we can read about IPV6 it is more related for the ISP provider ,we think they will still give a IPV4 for the LAN ROUTER of the customers.Will we still use IPV4 in LAN's in 10 years from now ? We do not see the benefit to have IPV6 in a HOME LAN

Tips:

  • IPV4 is not going away anytime soon . They are out of ipv4 addresses to give out though for public purposes . ISP's will be the first to convert I would think. I think you will see a "very slow" migration to ipv6 for corporate use. If you build a ipv4 lan today it is not going to be obsolete a year from now .
  • Most routers that have been built in the last few years should already be ipv6 capable . If you are talking old boxes like 2500 or 2600 then those might not be compatible.
  • Most likely issues with IPv6 support end to end in a system will not typically be with the switches and routers (assuming they are Cisco or otehr enterprise class gear of, say, a vintage from the past 5 years or less) but rather in any services platforms that may be in the systems and end user devices or appliances. Things such as load balancers, firewalls (though most enterprise level firewalls support IPv6), devices with embedded operating systems, management systems, etc. will give you issues more likely than your network infrastructure.I recently upgraded some segments of our network to support native IPv6 (i.e., IPv6 up throught the host operating systems from remote clients across the Internet). The only hardware I had to replace was a Cisco ACE-20 load balancer. I had to upgrade the image on my 6509 core and get my providers to add IPv6 to my border routers once we got a registered IPv6 address range from ARIN (that would be RIPE in EMEA or APNIC in Asia). Everything pretty much worked as advertised once I did that.
Citation - This blog post does not reflect original content from the author. Rather it summarizes content that are relevant to the topic from different sources in the web. The sources might include any online discussion boards, forums, websites and others.

Ether-Channelling between 6509 switches-do we need to shutdown the interface and check any other parameters.

We are unable to setup layer 2 ether channelling between 6509 switches.

Please confirm if the following commands are correct!

6509-cs1 ---------------------- 13/14-------------------------3/1-------6509-cs2

- ------------------------13/15-------------------------3/2-------

Creating port-cahnnel interface on two switches

interface port-channel 125

switch port

switch port trunk encapsulation dot1q

no ip add

assigning interface to port-channel on switch 1

Interface gi 13/14

switch port

switch port trun enc dot1q

no ip add

channel-group 125 mode on

!

Interface gi 13/15

switch port

switch port trun enc dot1q

no ip add

channel-group 125 mode on

assigning interface to port-channel on switch 2

Interface gi 3/1

switch port

switch port trun enc dot1q

no ip add

channel-group 125 mode on

!

Interface gi 3/2

switch port

switch port trun enc dot1q

no ip add

channel-group 125 mode on

While enabling these setup do we need to shutdown the interface and check any other parameters.

Tips:

Please see the below sample config from best practices.

ETHER CHANNEL CONFIG:
interface Port-channel125
switchport
switchport trunk encapsulation dot1q
switchport trunk native vlan xx
switchport mode trunk
ASSIGN PORT:
interface GigabitEthernet13/15
description xxxxxxxxxx

switchport trunk encapsulation dot1q
switchport trunk native vlan xx
switchport mode trunk
channel-group 1 mode on
You need to give "no shut" after you assign some port.

By default native vlan is 1.You only need to add the native vlan command, if you change it from default.

Citation - This blog post does not reflect original content from the author. Rather it summarizes content that are relevant to the topic from different sources in the web. The sources might include any online discussion boards, forums, websites and others.

Tuesday, February 22, 2011

Another copy process is active, please try again later.Is this a fundamental problem of the 300 Series?

We have a major problem with two new Small Business 300 Series switches.Everytime we try to save the running config we get a GUI error message: "Another copy process is active, please try again later." It's also not possible to re-flash the firmware because the GUI stops responding.We have also tried to do this via console access and this produces a "the copy utility is occupied by another user" error message.So this is not a browser based problem.
Our first thought was that the switch (SG 300-28) is faulty so we unpacked the next new one (SF 300) and got the same error messages!

Then we had a 2 hour webex support session with the Cisco Small Business Support and they did not found a reason for this behavior.Both switches works normally, can configure them, but after a reboot they are back to factory default again . There is no possibilty for copy running config to startup config and it's also not possible to flash the firmware.(Web GUI & Console).

Is this a fundamental problem of the 300 Series?

Tips:

Do you have option 67 set on your DHCP server? Because, it would seem, the SG300 loads whatever file you have defined by option 67, and tries to parse it as a configuration file. Now, in my case, that file (which is the default for my LAN) happens to be a PXE loader, and apparently attempting to parse that file throws my switch into a fit. Disabling option 67 or disabling DHCP altogether seem to make the device much happier.

The removal of option 67 for the DHCP lease of our SB300 switch is one solution .

Citation - This blog post does not reflect original content from the author. Rather it summarizes content that are relevant to the topic from different sources in the web. The sources might include any online discussion boards, forums, websites and others.
 
/* Google Analytics begin ----------------------------------------------- */ /* Google Analytics end ----------------------------------------------- */