Search this Blog

Tuesday, March 22, 2011

How to achieve a 2gb RX speed on this setup?

Qsolved Question : Currently we have a HP DL360 with 2* NC373i nic on the server and it is connected to the cisco 3750switch.

on the server we have SLB setup and with auto load balancing (assuming it will use TCP to load balance).On the switch have 1 portchannel setup with channel-group 1 mode active setup on the port. we have seen, 2gb TX, RX showing on the HP software however when we do a TX a large file toward one server (1ip, mac) the speed will stay at 1gb tx when tx 2file to 2 server we will get 2gb tx speed. However RX is always stay at 1gb no mater if i copy from single source or multi source. (cisco switch have setup load balancing from source MAC)

1. HP and cisco switch with a point to point file copy and achieve 2GB TX and RX speed? ( so we can save and not buying 10GB card/switch)

2. how to achieve a 2gb RX speed on this setup?

We have tried this doc, no luck with 802.3ad as the HP software will only recognize the RX port is 1gb only.

http://www.cisco.com/en/US/tech/tk389/tk213/technologies_configuration_example09186a008089a821.shtml

Qsolved Answer :

setup with the following command and selections.

On the Cisco switch...

interface Port-channel55
description HPServer EtherChannel
switchport
switchport access vlan 3
switchport mode access
spanning-tree portfast

interface GigabitEthernet5/10
description HPServer EtherChannel
switchport access vlan 3
switchport mode access
channel-group 55 mode active
spanning-tree portfast
!
interface GigabitEthernet5/11
description HPServer EtherChannel
switchport access vlan 3
switchport mode access
channel-group 55 mode active
spanning-tree portfast

On the server.....

Team Type Selection:
802.3ad Dynamic with Fault Tolerance

Transmit Load Balancing Method:
Destination IP Address

Go to the Infomation tab and verify
under the "Role" columb that both
NICs show Tx/Rx.

Get it working with one server towards multi-dest RX/TX achieved 2gb speed. We think with lacp, one to one copy will be limited to 1gb speed. (unless anyone know how???? would love to have our backup server copying at 2gb speed) the only thing we think we did do before is shutdown both nic and and no sh again. Also we have applied portfast on port-channel.

Citation - This blog post does not reflect original content from the author. Rather it summarizes content that are relevant to the topic from different sources in the web. The sources might include any online discussion boards, forums, websites and others.

1 comment :

  1. hi,
    Really liked your website really got your point acrosss. Found it while going through google so wanted to tell you good job and you have a bookmark from me.
    Dl380g6

    ReplyDelete

 
/* Google Analytics begin ----------------------------------------------- */ /* Google Analytics end ----------------------------------------------- */